为什么用龙蜥?

最近的CentOS8结束生命周期闹得沸沸扬扬,经过对目前现有国产操作系统总结归纳,龙蜥可做到CentOS8一键升级到龙蜥,且应用稳定性可以保障。但你要说他是挂皮的CentOS,也不尽然,我比较看重它重构CentOS后新增加的一些功能,龙蜥8.6是双内核,RHCK(RHEL Compatible Kernel)和ANCK(OpenAnolis Cloud Kernel),其中ANCK内核有阿里团队重点打造,且经过了阿里各种重大市场活动的检验,最主要的是Cgroup功能,可以防止有BUG的应用不断蚕食系统资源,导致系统崩溃的情况发生。

安装Confluence数据库需关注的重点

安装MySQL或MariaDB数据库不是本篇重点,但这里面务必需要按照Confluence官方文档来设置,这样才能减少踩坑的几率。

具体参照如下文档
https://confluence.atlassian.com/doc/database-setup-for-mysql-128747.html

BIN包安装Confluence7.19.1

说几个重点需要关注的地方
1、采用atlassian-agent方式,把启动写入setenv.sh最为稳妥
2、如果不是一次安装成功的,一定要注意,每次安装BIN包都会新建立一个confluence账户,比如第一次建立一个confluence,第二次就是confluence1,第三次就是confluence2,以此类推,然后我这次碰到的一个诡异的问题就是使用startup.sh启动一切正常,使用start-confluence.sh启动就会报权限错误,根据观察使用startup.sh启动使用root权限,使用start-confluence.sh启动使用的是最后一次安装成功的confluence【1-*】用户权限,但是如果你想系统开机启动confluence,那使用的必然是start-confluence.sh文件,目前可以通过修改user.sh中的启动用户来解决这个问题,但这不是官方解决方式,所以这个东西务必还是一次安装好。
3、新系统不要升级安装,建议新安装一套,然后使用旧系统的备份数据还原即可。

结尾放张图,上线测试中。。。

原创文章,转载请注明: 转载自混沌

本文链接地址: 在龙蜥8.6上安装Confluence7.19.1