大概浏览了一下,网上很多是用 pip 卸载后重新安装,不过我的系统是Python2和python3共存,其实这个提示已经很清楚了——系统的libcurl库文件和后安装的不一致。
系统中,我们后安装的libcurl库一般都在/usr/local/lib中,一般有两个文件,以我的系统为例
libcurl.so
libcurl.so.4 -> libcurl.so.4.5.0

然后系统自带的libcurl库,在/usr/lib64中,目前只发现一个文件
libcurl.so.4 -> libcurl.so.4.3.0

我们只要把新安装的 libcurl.so 和 libcurl.so.4.5.0 拷贝到 /usr/lib64 中,并删除原 libcurl.so.4 软链,并在 /usr/lib64 中建立新的 libcurl.so.4 软链文件
# ln -s libcurl.so.4.5.0 libcurl.so.4

然后再import的时候就不会报错了

当然有条件用pip安装最好,依赖性都不用自己解决。但是我这种两个版本共存的时候,pip安装时候经常会报错,就必须用源代码安装了。

原创文章,转载请注明: 转载自混沌

本文链接地址: 关于Python3 报pycurl: libcurl link-time version的另一种解决方法