转到正文

存档

分类: 技术文章

大概浏览了一下,网上很多是用 pip 卸载后重新安装,不过我的系统是Python2和python3共存,其实这个提示已经很清楚了——系统的libcurl库文件和后安装的不一致。
系统中,我们后安装的libcurl库一般都在/usr/local/lib中,一般有两个文件,以我的系统为例
libcurl.so
libcurl.so.4 -> libcurl.so.4.5.0

然后系统自带的libcurl库,在/usr/lib64中,目前只发现一个文件
libcurl.so.4 -> libcurl.so.4.3.0

我们只要把新安装的 libcurl.so 和 libcurl.so.4.5.0 拷贝到 /usr/lib64 中,并删除原 libcurl.so.4 软链,并在 /usr/lib64 中建立新的 libcurl.so.4 软链文件
# ln -s libcurl.so.4.5.0 libcurl.so.4

然后再import的时候就不会报错了

当然有条件用pip安装最好,依赖性都不用自己解决。但是我这种两个版本共存的时候,pip安装时候经常会报错,就必须用源代码安装了。

首先,我们要说Centos7这个版本和之前的版本有很多不同之处,中文字符支持这件事也是如此
1、在我负责的系统中,都是最小化安装,安装的时候就要安装中文语言支持包。
2、修改/etc/locale.conf为如下
LANG=”zh_CN.UTF-8″
3、重启,再说一遍,必须重启系统,而不是用什么source的方法
4、重启登陆,不管用Securecrt,还是其他putty啥的,会发现之前显示正常的英文都变乱码了,但如果你在机器上插显示器,其实还是英文提示,如下图

看来,只有 Securecrt 或者 Putty 受影响了,所以我们要从软件上找原因,而不是从系统中找。我们以Securecrt为例,需要修改的地方如下

字体我们选用中文仿宋,字符编码,我们要选用UTF-8,因为Linux系统都是UTF-8编码。关闭设置后,重新登陆系统。我们已经能看到中文正常显示了,如下图,再啰嗦一下,如果这台服务器插上显示器,“ 总用量 ”那里不是中文,还是英文,从这里充分说明,目前还只是系统支持中文显示,而这种中文显示,是需要用客户端配合服务器端实现的。

继续阅读

Centos 7 参考如下链接:https://extras.getpagespeed.com/redhat/7/x86_64/RPMS/
里面有很多rpm包的插件,安装完成后,只要在 nginx.conf 第一行添加
load_module “modules/ngx_http_fancyindex_module.so”;
即可。

但是,也有一些插件是不提供rpm包封装的,比如
ngx_cache_purge-2.3

如果需要添加插件,这个就麻烦一点,比如我yum安装的nginx版本是1.14.2,那我需要去nginx.org 下载同样版本的tar包,解压缩。

# nginx -V
看看nginx yum 安装的参数,copy下来
# mv /usr/sbin/nginx /usr/sbin/nginx.bak
# mv /etc/nginx /etc/nginx.bak
备份之前没添加模块的nginx程序
# cd nginx-1.14.2
将之前nginx的安装参数照写一遍,后面添加
–add-module=../nginx-cache-purge-module
# make;make install
# nginx -V
看看是不是已经添加了模块

# rm -rf /etc/nginx
# mv /etc/nginx.bak /etc/nginx
# nginx -s reload
如果没有错误,yum安装的nginx就完成了挂载插件了。

1、播放音乐:Alt+blank,Alt+f 下一曲
2、TTS阅读:Shift+Sym
3、恢复出厂设置:按住电源键20秒以上关机,再按住Home键,滑动电源键开机,直到出现画面,松开Home键,输入reset,跳出一进度条,进入Recovery Mode,按R重启
4、浏览器删除收藏:方向键左
5、浏览器编辑收藏:方向键右
6、进debug改地区(改后其实并不能显示中文):
按home键,返回书目,按回车,然后:
;debugOn

`help #测试一下是否用`有的版本需要用 ~
`changelocale zh-CN #有的版本需要zh-CN.utf8
;debugOff

7、截屏:Alt+Shift+G 图片保存在documents目录中
8、扫雷游戏:Alt+Shift+m
9、五子棋:打开扫雷时,按g
10、关于美版DXG 序列号为B009开头的机器汉化的方法,不升级系统,还是用原生的2.5.8版本

继续阅读

这个其实很简单,因为安装的时候使用的KEY是官方申请的,所以有过期一说,如果有这个提示,需要我们去官方升级一下,但这个情况是偶发,我16年应已过期的KEY,一直用到今年升级6.13才报出这个问题。

申请后,会出现

你的Confluence技术支持与更新服务将于XXX到期

6.13 目前版本已经测试,继续使用我们之前6.11的俩个文件即可。

安全证书这个事情,有花钱的解决方案,还有不花钱的解决方案。咱们今天讲讲不花钱的方法,https://www.sslforfree.com/ ,在这个网站申请的证书,90天使用期,90天以后还需要重新申请。

第一步:生成SSL域名证书

点击Create Free SSL Certificate 生成域名证书

继续阅读

由于想测试一下Hipchat-server,但是没想到的是主站已经不能申请下试用key了!求助广大网友,谁有安装key,给一个用用,让我也体验一把。可以发到我的信箱:xu1701@hotmail.com,感谢!

https://confluence.atlassian.com/confkb/how-do-i-ensure-excel-file-with-wide-columns-does-not-get-truncated-in-confluence-file-previews-829068467.html

Purpose
This article contain instructions on how to change the display of excel files in confluence File Preview / light box, mainly because by default, confluence file preview will truncate excel files with wide columns/ excel files with huge number of columns.

For example, below is a sample excel file with a huge number of columns:

Upon uploading to confluence, the columns will be truncated and will be displayed as below:

继续阅读

升级VCENTER到6.7U1后,VEEAM开始不正常了,不能备份,报错全是——未将对象引用设置到对象的实例。

这个其实VEEAM的官方团队已经注意到,并且给出了解决方案:

Solution

Create the following registry value under HKLM\SOFTWARE\Veeam\Veeam Backup and Replication key on the Veeam Backup and Replication server:

Please, note that value and data fields should not contain any spaces.

Value: VMwareOverrideApiVersion
Type: Multi-String Value (REG_MULTI_SZ)
Data: 6.7.1=6.7

Then reboot the Veeam Backup and Replication server.
目前VEEAM版本是9.5 update 3a ,next release (Update 4) 将把此问题的解决加入进去,目前必须手动解决这个问题。

瞎折腾第一篇:我如何实现的手机离线导航及轨迹记录

瞎折腾第二篇:PAPAGO 315 WIFI 行车记录仪深度使用测试(含GPS)